[lfs-support] LFS 7.1, a problem

Jean-Philippe MENGUAL jmengual at linuxfromscratch.org
Sat Nov 10 04:09:01 PST 2012


To complete, I have a logmessage now which says, after I added some
"read" and "echo" to S00mountvirtfs:
/lib/lsb/init-functions:679: cn't find /run/var/bontlog no such file or
dir

Weird.

-  
       Jean-Philippe MENGUAL
       Président de l'association traduc.org 
       Coordinateur du projet Linux From Scratch
       Coordinateur au sein du projet Trad GNU de l'April
       Animateur suppléant du groupe de travail Accessibilité de l'April



Le samedi 10 novembre 2012 à 12:39 +0100, Jean-Philippe MENGUAL a
écrit :
> > There are a couple of things.  What are the contents of your fstab?
> > 
> > /run and /dev should be specified as
> > 
> > tmpfs    /run tmpfs    defaults          0     0
> > devtmpfs /dev devtmpfs mode=0755,nosuid  0     0
> 
> Yes, I have these 2 lines.
> 
> > I'd suggest updating the LFS bootscripts to the latest version.  Thy 
> > won't break anything and we can be specific about what is happening.
> 
> Done.
> 
> My kernel has the option "maintain a devtmpfs" enabled.
> 
> And it doesn't work.
> 
> 
> > In any case, mountvirtfs is the first script.  It should mount /run as a 
> > tmpfs and then create /run/{var,shm,lock}.
> > 
> > mountvirtfs also mounts /proc, /sys, and /dev if needed (the kernel 
> > should have already done that).
> > 
> > Also note that the kernel must have devtmpfs enabled.  See Chapter 8.3.
> 
> Done.
> 
> > At this point you can also make temporary changes to mountvirtfs and add 
> > some relevant echo or ls statements to try to understand what is happening.
> 
> What kind of change is possible? I study the script but I am somewhat lost :)
> 
> Best regards,
> 
> >    -- Bruce
> -  
>        Jean-Philippe MENGUAL
>        Président de l'association traduc.org 
>        Coordinateur du projet Linux From Scratch
>        Coordinateur au sein du projet Trad GNU de l'April
>        Animateur suppléant du groupe de travail Accessibilité de l'April
> 
> 
> 
> Le vendredi 09 novembre 2012 à 21:19 -0600, Bruce Dubbs a écrit :
> > Jean-Philippe MENGUAL wrote:
> > > Hi,
> > >
> > > As I finished a lfs 7.1 before 7.2 release, I try finishing before
> > > updating. And I have a boot problem.
> > > 1. My tmpfs entry in fstab is good. My dev entry too.
> > > 2. CONFIG_TMPFS=y
> > > 3. I have a /run dir
> > >
> > > 1st thing strange: I don't understand, in the book, "ln
> > > -s /run/lock /var/lock" (chap6.5) which creates a broken symlink ( /run
> > > is empty). Moreover, at boot, I get a message: "cannot find /dev in
> > > fstab" then "can't find /run/var/bootlog".
> > >
> > > Could it be a kernel problem? A bootscript problem? Can I workaround or
> > > fix?
> 
> 




More information about the lfs-support mailing list