[lfs-support] Virtual box

doak at gmx.de doak at gmx.de
Mon Nov 5 04:54:26 PST 2012


Hi,

I started LFS using VirtualBox sometime ago (version 6.3?) and run into 
problems during gcc tests. There were some bad failures as well as bad 
successes regarding (if I rememeber correctly) scheduling/threads.
I tried it natively and that did work.
(The hardware was an Apple MacBook Core Duo.)

Anway, does nobody else had strange test results using VirtualBox? Only me?

(A little bit off-topic: I use VirtualBox (Windows host, Linux guest) to 
build some project and I found a reproducable bug which causes some files 
not to be rebuild after beeing changed. I use a script which replaces 
symlinks and I guess some meta data is not written/synced correctly. VMWare 
does not show this bug, but is slower in execution .. ;) So... imho you 
should at least pay attention if something goes wrong.)

But you are right, snapshotting is/would be very helpfull.
Using btrfs instead of ext3 is no alternative as this causes a big 
deviation, I guess.

Regards,
doak


------- Original message -------
> From: Thomas de Roo <thomas at de-roo.org>
> To: lfs-support at linuxfromscratch.org
> Sent: '12-11-05,  13:30
>
> On 11/05/12 08:27, Rahul Udasi wrote:
>> Hi, has anyone built lfs on a virtual machine?
>>
>>
>> Sent from my BlackBerry device on the Rogers Wireless Network
>>
> I have built LFS on VMware Player, VMware Sserver, VMware ESXi and
> VirtualBox. The snapshot-feature is great, use it!
>
> Groet,
> Thomas 



More information about the lfs-support mailing list