[lfs-support] gmp problem in chapter 6

Simon Geard delgarde at ihug.co.nz
Mon Mar 26 00:59:21 PDT 2012


On Sun, 2012-03-25 at 08:16 -0500, mike wrote:
> hi,
> 
> i get to configuring gmp i ran the following and this is what i get and am
> confused on how to fix. Any guidence  wood be helpfull
> 
> root:/sources/gmp-5.0.4# ABI=32 ./configure ...
> 
> configure: WARNING: you should use --build, --host, --target
> 
> checking build system type... Invalid configuration `...': machine `...' not
> recognized                                      

Ah. I guess the book could be clearer on this, but when it says "..." in
that line, that's not meant to be literal. The intention is that you
should run the normal configure line (the one with --prefix, etc) but
with ABI=32 added to the start of the line.

LFS devs - can we maybe change the wording on this? Either use a 'case'
block like we do elsewhere in the book, or just remove that command
entirely, and rewrite the note to say "Add the string 'ABI=32' to the
beginning of the command below". I'd also upgrade it from a Note to an
Important block, since it results in errors if you don't do it.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120326/610d8ad1/attachment.sig>


More information about the lfs-support mailing list