[lfs-support] usb mouse connects=disconnects repeatedly

alupu at verizon.net alupu at verizon.net
Sun Mar 11 19:41:26 PDT 2012


Hi Martins,

>... the usb mouse I have connected seems to be constantly disconnecting and reconnecting
> after the system boots, filling the screen constantly connect/disconnect messages
> like the following ...


I wouldn't chuck my mouse out the window yet.
I've been plagued by these nonsensical (to me) messages for quite a long time.
For additional fun I even went to the '/etc/rc.d/init.d/localnet' script and inserted
a "read" line
...
 stop)
 log_info_msg "Bringing down the loopback interface..."
read
 ip link set lo down
...
Obviously after making a backup of the original file, etc.
The "read" command forces the script to stop "advancing" beyond it until
the user hits a key.

On rebooting the machine the display will stop at this next-to-last script
(the last is 'reboot') and after every minute or so I'd get a bunch of four
messages similar to yours (disconnect/connect) related to my
USB Microsoft mouse existence on my system

I'd watch the screen rapturously for about 5-10 min. (I don't have much of a life)
and then give up (hitting a key) and go to yet another productive activity.

I'm truly very busy now but I remember I wrote to the guy who was responsible
for the kernel input drivers (and then some) and asked about this USB phenomenon.
He answered my technical question very clearly and logically.
He should know.
I didn't understand (or agree) too much but it made me accept
the USB mouse with a smile on my face and live with it from then on.
Obviously, you get to accept the situation like car alarms and other life vicissitudes
but life goes on anyway.

If you haven't gotten rid of your mouse and are still interested in
his wise words, I might be able to publish his answer for you in a few days.


Good luck in all your endeavors,
-- Alex

 



More information about the lfs-support mailing list