[lfs-support] Linux 3.1 API headers headers_check Errors

Kyle Brennan kyle_bren at live.com
Tue Feb 28 09:13:35 PST 2012

>On Tue, 28 Feb 2012 00:06:51 -0700
>Kyle Brennan <kyle_bren at live.com> wrote:
>> Hi, 
>> I am attempting my first LFS build, and I got to step 5.5 in the
>book, and everything goes as normal until I hit the command "make
>headers_check" which gives me multiple errors.  they are outlined
>> /mnt/lfs/sources/linux-3.1/usr/include/drm/drm_mode.h:85: found
>__[us]{8,16,32,64} type without #include
>found __[us]{8,16,32,64} type without #include
>found __[us]{8,16,32,64} type without #include
>found __[us]{8,16,32,64} type without #include
>found __[us]{8,16,32,64} type without #include <linux/types.h>
>> /mnt/lfs/sources/linux-3.1/usr/include/linux/mmc/ioctl.h:10: found
>__[us]{8,16,32,64} type without #include <linux/types.h>
>> /mnt/lfs/sources/linux-3.1/usr/include/linux/soundcard.h:1054:
>userspace cannot reference function or variable defined in the kernel
>> /mnt/lfs/sources/linux-3.1/usr/include/scsi/scsi_netlink.h:108: found
>__[us]{8,16,32,64} type without #include <linux/types.h>
>> I'm not sure if this is relevant, but my build environment is Ubuntu
>11.10 32bit, running in virtualbox.  I have fulfilled all the
>prerequisites for the build, noting that the version_check.sh that was
>instructed to be run succeeded with proper versions.  I've tried
>recompiling it multiple times, and I cant seem to get it to work.  Can
>someone advise me on what to do to solve this?
>Solve what?

Okay.  So I did a terrible job explaining what my issue is.  I am getting these errors above when I run the headers check.  I'm not sure if they are normal or not, I tried looking them up and found nothing.  I would like to find out if these errors are normal and if they are not, I need to fix them.


>FAQ: http://www.linuxfromscratch.org/lfs/faq.html
>Unsubscribe: See the above information page

More information about the lfs-support mailing list