[lfs-support] Boot message log location

Eleanore Boyd cara117 at cox.net
Fri Aug 31 13:42:43 PDT 2012

On 8/31/2012 3:32 PM, Mikie wrote:
> Tried and Tried but could not stop the display during boot so ...
> I took a vid:
> http://www.mikienet.com/linux/VID_20120831_150531.3gp
> at 14 seconds it says:
> mount: unknown filesystem type 'devtmpfs'
> ln: failed to create symbolic link '/dev/shm': Read Only file system
> cp: cannot remove '/dev/null': Read-only file system
> *****										[FAIL]
> *****										[FAIL]
> You should not be reading this error message.
> It means that an unforeseen error took place in
> /etc/rc.d/rcS.d/S00mountvirtfs.
> which exited with a return value of 1.
> If you're able to track this error down to a bug in one of
> the files provided by the files provided by
> the book, please be so kind to inform us at
> lfs-dev at linuxfromscratch.org (Registration required).
> *****										[FAIL]
> 	Press Enter to continue
It seems to me that the kernel is missing the option for devtmpfs, 
whichever one that is. You could try recompiling the kernel from the 
host system and see what happens. If that doesn't work, either something 
is really wrong, or one of the editors will know the magic formula. Yay 
magic formulas. (I know, if only...)


More information about the lfs-support mailing list