[lfs-support] e2fsprogs

Bruce Dubbs bruce.dubbs at gmail.com
Tue Aug 28 14:34:49 PDT 2012


Mike Johnston wrote:
> Maybe I'm dense here, but the Util-Linux doesn't have a fsck.ext2 or
> fsck.ext3 in it's list of programs installed.  Which module installs
> an fsck capable of ext2/3 filesystems?
>
> When I built Util-linux I didn't get a fsck.ext2 or ext3.  I only saw
> those if I left the --disable-fsck off the e2fsprogs configure.

Please don't top post.

 From my e2fspros log, I have:

...
Not building fsck wrapper
...
    MKINSTALLDIRS /sbin /usr/share/man/man8
    INSTALL /sbin/e2fsck
    LINK /sbin/fsck.ext2
    LINK /sbin/fsck.ext3
    LINK /sbin/fsck.ext4
    LINK /sbin/fsck.ext4dev

The programs are being installed by e2fsprogs.  It's the wrapper script 
that is installed by util-linux.

   -- Bruce





More information about the lfs-support mailing list