[lfs-support] e2fsprogs

Bruce Dubbs bruce.dubbs at gmail.com
Tue Aug 28 13:58:21 PDT 2012


Mike Johnston wrote:
> So I built util-linux-2.20.1 and it has fsck, fsck.minix.
>
> Building e2fs the command line in the 7.1 book has the
> "--disable-fsck" flag in the configure.  This prevents the ext2/3/4
> from being built.
>
> The list of installed programs lower in the book shows them being
> installed. I'm just not sure how that can be if we didn't build
> them.

That appears to be left over from earlier versions.  The comment in the 
e2fsprogs text is correct:

"--disable-*

     This prevents E2fsprogs from building and installing the libuuid 
and libblkid libraries, the uuidd daemon, and the fsck wrapper, as 
Util-Linux installed all of them earlier."

   -- Bruce



More information about the lfs-support mailing list