[lfs-support] Link to libbz2.so

Eleanore Boyd cara117 at cox.net
Fri Aug 24 13:54:30 PDT 2012

On 8/24/2012 3:40 PM, Feuerbacher, Alan wrote:
> Bruce Dubbs wrote:
>>> My ldconfig doesn't have a -a option.
>> Sorry. Without the link and as root:
>> # ldconfig -v | less
> What does running this as root get you as opposed to running it as a regular user? I don't have root access. So I ran this as a regular user.
> I'm doing all this in unusual circumstances but it's a long story. Basically I'm using LFS as a basis for installing a system in parallel with the existing Redhat (RHEL5) system. The system is not my own but my company's system, and I'm not allowed to mess with the actual operating system. Nor can we upgrade to a newer system for various reasons. So I have to install everything in my own directories. I've succeeded in doing this, and am now tying up a lot of loose ends.
> So in these emails when I write /usr/lib, what I really have is /home/afbacher/LFS71/lfs80/usr/lib, and I'm chopping out the stuff I think is irrelevant to getting help from you gurus.
>> The /lib section should have libbz2.so.1.0 -> libbz2.so.1.0.6
> There are no entries anywhere for this stuff.
>> Then
>> $ ls -l /lib/libbz*
>> lrwxrwxrwx 1 root root    15 Aug 22 05:24 /lib/libbz2.so.1.0 ->
>> libbz2.so.1.0.6
>> -rwxr-xr-x 1 root root 69018 Aug 22 15:43 /lib/libbz2.so.1.0.6
> Doing the equivalent, and not chopping anything out, I get this:
> afbacher:~/LFS71/lfs80/lib$ ls -l /home/afbacher/LFS71/lfs80/lib/libbz*
> lrwxrwxrwx 1 afbacher pmbude   15 Aug 22 10:55 /home/afbacher/LFS71/lfs80/lib/libbz2.so.1.0 -> libbz2.so.1.0.6*
> -rwxr-xr-x 1 afbacher pmbude 219K Aug 22 09:41 /home/afbacher/LFS71/lfs80/lib/libbz2.so.1.0.6*
> afbacher:~/LFS71/lfs80/lib$ ls -l /home/afbacher/LFS71/lfs80/usr/lib/libbz*
> -rw-r--r-- 1 afbacher pmbude 343K Aug 22 09:45 /home/afbacher/LFS71/lfs80/usr/lib/libbz2.a
> lrwxrwxrwx 1 afbacher pmbude   23 Aug 22 10:56 /home/afbacher/LFS71/lfs80/usr/lib/libbz2.so -> ../../lib/libbz2.so.1.0*
> lrwxrwxrwx 1 afbacher pmbude   23 Aug 24 15:09 /home/afbacher/LFS71/lfs80/usr/lib/libbz2.so.1.0 -> ../../lib/libbz2.so.1.0*
> I suspect that something to do with ldconfig is my problem, but I don't understand how that plays into the complete Linux system.
> Alan
This might be completely off-topic, but have you tried using a VM to 
build LFS? I have seen some portable versions of VirtualBox on the 
Internet, and using a live cd to build the system inside a VM might 
solve some problems. After that, it would be up to you to prove that 
your system is better than the Redhat systems still in use at your company.


More information about the lfs-support mailing list