[lfs-support] Perl-5.16.1 test failures in Ch 6 SVN-20120816

Bruce Dubbs bruce.dubbs at gmail.com
Mon Aug 20 10:03:01 PDT 2012


Eleanore Boyd wrote:
> On 8/20/2012 9:09 AM, Ken Moffat wrote:
>> On Mon, Aug 20, 2012 at 12:56:56PM +0100, Richard Melville wrote:
>>> On Mon, Aug 20, 2012 at 12:04:49AM +0100, Ken Moffat wrote:
>>>>>     Unfortunately, this was unlogged and scrolled out of my
>>>>> term's buffer - it then died with an EPERM trying to create
>>>>> test-suite.log.tmp so I've now started it again, after chown me
>>>>> ../automake-1.12.3.
>>>>    So, in effect that is chown -R some-normal-user ../automake-1.12.x
>>>>
>>>>    If you are interested, compare what we do for the coreutils tests.
>>>> [ if you aren't, I understand ]

>>>>
>>> Thanks for the really detailed replies Ken -- it's much appreciated.
>>>
>>> I'm building this when I have the spare time; I'll see if I can run the
>>> tests tonight and get back to you.
>>>
>>> Richard
>>    Thanks, but perhaps not necessary - it seems to be a problem at my
>> end (see Bruce's response, and my reply to that).  In particular,
>> the "run as a regular user" seems NOT to be the key.

> If running as a regular user isn't the key, and no one else is getting
> anywhere with it, them maybe it's a bug in Perl itself? What if they
> need to change how they read timezones, and how they read and make
> timestamps? It's the only thing I can think of that might be wrong at
> this point.

No, it's our installation of timezones.  See my post on lfs-dev.  I now 
have no errors in the perl checks.

   -- Bruce





More information about the lfs-support mailing list