[lfs-support] Udev installation error - LFS chapter 6

Oshadha Gunawardena oshadha.rocky at gmail.com
Mon Aug 20 09:36:43 PDT 2012


@Aleksandar Kuktin
I'm referring to LFS book 7.1 and it is the latest stable release that can
be found. I couldn't find any pkg-config related information in this book,
I will check older versions of LFS books

@Ken Moffat
Yes, I'm still trying to fix this issue. As I mentioned earlier I have
completed the entire chapter 6 without installing udev package.

So I would also like to know, if I'm going to repeat the section 6 again
what precautions should I take to prevent any installation errors and how
do I handle the already installed packages? Basically how do I revert back
to the beginning of section 6?

On Mon, Aug 20, 2012 at 8:31 PM, Aleksandar Kuktin <akuktin at gmail.com>wrote:

> >On Mon, 20 Aug 2012 17:33:08 +0530
> >Oshadha Gunawardena <oshadha.rocky at gmail.com> wrote:
> >
> > Tried that, and I managed to configure it (trace -
> > http://tny.cz/5f221035). But came out with a new error please refer
> > the below trace
> >
> >   configure: error: The pkg-config script could not be found or is too
> >   old.  Make sure it
> >   is in your PATH or set the PKG_CONFIG environment variable to the
> > full path to pkg-config.
>
> It appears you are missing pkg-config and/or glib.
>
> These packages were at first not in LFS, then they were added because
> something (can't remmember what) had pkg-config as a dependency and
> glib depends on glib. Later, the two packages were removed because
> they were adding too much cruft to the book.
>
> Now, the details of the resolution of your problem (assuming the
> problem is in a missing package) depend on which exact versions of the
> book and udev package you are using. I am not an editor and have not
> read the new versions of the book so I may give you bad information.
> However, I guess that if you take the newest release of the book and
> the release of udev that said book references, you will succed.
>
> Make sure to check if the particular version of the book you use has
> pkg-config, and if it does, do not skip it. Same for glib. In any case,
> match the version of udev you are trying to build with the version the
> book references.
>
> --
>    Fourth law of programming:
>    Anything that can go wrong wi
> sendmail: segmentation violation - core dumped
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120820/59841a8e/attachment.html>


More information about the lfs-support mailing list