[lfs-support] Udev installation error - LFS chapter 6

Oshadha Gunawardena oshadha.rocky at gmail.com
Mon Aug 20 03:39:54 PDT 2012


No, the problem came even I correctly entered the command as in *one* line
otherwise I wouldn't be able to set the PKG_CONFIG flag.

Thanks.

On Mon, Aug 20, 2012 at 1:37 PM, Jasmine Iwanek <jasmine at iwanek.co.uk>wrote:

> On 2012-08-20 07:04, Oshadha Gunawardena wrote:
> > You can find the full trace here http://tny.cz/731e9d9b [1]
> >
> > I was trying the LFS book and stuck at this point where udev-181 hits
> > a build error. I completed the chapter 6 without installing udev and
> > I
> > know it will be a problem in the future. So now I want is a solution
> > for building and installing udev and set or recreate the environment
> > ready for the future.
> >
> > INITIAL ERROR:
> >
> > configure: error: in `/sources/udev-181:
> >
> > configure: error: The pkg-config script could not be found or is too
> > old.  Make sure it
> > is in your PATH or set the PKG_CONFIG environment variable to the
> > full
> > path to pkg-config.
> >
> > Alternatively, you may set the environment variables BLKID_CFLAGS
> >
> > and BLKID_LIBS to avoid the need to call pkg-config.
> > See the pkg-config man page for more details.
> > I set the pkg-config flag to PKG_CONFIG=/tools/bin/true. But then it
> > asked for GPERF, so I installed GPERF and it seems configured fine
> > (full trace of configuration command - http://tny.cz/5f221035 [2])
> >  but I couldnt get it to compile because of the below error.
> >
> > ERROR:
> >
> >   # make
> >   GEN    test/sys/kernel/uevent_seqnum
> >   GEN    src/extras/gudev/gudevmarshal.h
> >   /bin/sh: glib-genmarshal: command not found
> >   make: *** [src/extras/gudev/gudevmarshal.h] Error 127
> >
> >  Thanks,
> > Oshadha.
> >
> >
> > Links:
> > ------
> > [1] http://tny.cz/731e9d9b
> > [2] http://tny.cz/5f221035
>
> Looking over your log you've done a copy and paste of the book
> instructions for this package, however several of the configure options
> have ended up on separate lines hence all the "command not found" lines
> in the log, follow the instructions in the book and make sure options to
> configure are on the same line as the configure command.
>
> At this point I would suspect that other packages in your build will
> have issues due to this and as such I would recommend that you start
> again, this time being very careful to follow the instructions exactly.
>
> --
> Jasmine Iwanek
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120820/84316213/attachment.html>


More information about the lfs-support mailing list