[lfs-support] LFS chapter 5.9 binutils pass 2 fails on make install step

Ken Moffat zarniwhoop at ntlworld.com
Sat Aug 18 16:56:37 PDT 2012


On Sat, Aug 18, 2012 at 10:26:48PM +0000, daveLin wrote:
> Hi,
> 
> LFS stable version 7.0 and my host system is Ubuntu lts 12.
> 
> While running the "make install" step on Binutils-2.21.1a - 
> Pass 2 chapter 5.9
> i'm getting errors.
> 
> Here is the log output
> 
> ../../binutils-2.21.1/libiberty/../include/demangle.h
> ../../binutils-2.21.1/libiberty/../include/dyn-string.h
> ../../binutils-2.21.1/libiberty/../include/fibheap.h
> ../../binutils-2.21.1/libiberty/../include/floatformat.h
> ../../binutils-2.21.1/libiberty/../include/hashtab.h
> ../../binutils-2.21.1/libiberty/../include/libiberty.h
> ../../binutils-2.21.1/libiberty/../include/objalloc.h
> ../../binutils-2.21.1/libiberty/../include/partition.h
> ../../binutils-2.21.1/libiberty/../include/safe-ctype.h
> ../../binutils-2.21.1/libiberty/../include/sort.h
> ../../binutils-2.21.1/libiberty/../include/splay-tree.h; do \
> 	    /usr/bin/install -c -m 644 $h ${thd}; \
> 	  done; \
> 	fi
> make[3]: Entering directory `/mnt/lfs/sources/binutils-build/libiberty/testsuite'
> make[3]: Nothing to be done for `install'.
> make[3]: Leaving directory `/mnt/lfs/sources/binutils-build/libiberty/testsuite'
> make[2]: Leaving directory `/mnt/lfs/sources/binutils-build/libiberty'
> make[1]: Nothing to be done for `install-target'.
> make[1]: Leaving directory `/mnt/lfs/sources/binutils-build'
> 
> I tried to re-install the package once again. But ended up with same result. 
> Any help would be greatly appreaciated.
> 
> Thanks
> 
 That doesn't show any errors.  Are you using the same
binutils-build or binutils-2.21.1a directories as you used in pass
1 ?  If you are, you need to remove them for each build.

 If you got this with freshly extracted source and a fresh build,
please log it, e.g.
make install 2<&1 | tee failed-install.log

 Doing it like that will let you watch while it runs - it is
important to capture the error message(s) which is/are probably on
stderr.

 7.0 is about a year old - if you have the bandwidth to download the
packages, 7.1 will be less old and some of the explanations might be
better.  We're *nearly* ready for 7.2, but at the moment there are some
"issues".

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the lfs-support mailing list