[lfs-support] coreutils-8.17 tests run as "nobody" fails

Bruce Dubbs bruce.dubbs at gmail.com
Sat Aug 18 09:06:08 PDT 2012

Richard Melville wrote:
> Richard Melville wrote:
>>> Some help with this would be great -- I just can't understand it.
>>> I ran the tests as root which ran OK.  I've added the temporary group and
>>> changed permissions but when I run:-
>>> su nobody -s /bin/bash -c "make RUN_EXPENSIVE_TESTS=yes -k check || true"
>>> It returns:-
>>> bash: make: command not found.
>> That's due to an issue associated with changes I made about 12 hours
>> ago.  Try:
>> su nobody -s /bin/bash -c "TZ=UCT0 /tools/bin/make
>> RUN_EXPENSIVE_TESTS=yes -k check || true"
>>     -- Bruce
> Thanks Bruce -- the "nobody" test suite now runs but all tests fail owing
> to mv and grep not being found :-(
> Maybe I should just move on.

That would be best for you until I get this fixed.  The problem is that 
we are using a different version of su in Chapter 6 than we used to use. 
  The old version was from coreutils.  The new version is from shadow 
and the behavior is different.  Specifically it changes PATH and 
/tools/bin is missing.  I need to correct the path for these tests to work.

Another option is to run the tests after coreutils make install.

   -- Bruce

More information about the lfs-support mailing list