[lfs-support] e2fsprogs test failures on version SVN-20120806

Lewis Pike phaselocker at gmail.com
Fri Aug 17 13:04:58 PDT 2012

Bruce Dubbs wrote:
> Lewis Pike wrote:
>> Digging a bit deeper into the test suits logs does indeed reveal a
>> difference of 18 seconds on the time stamps.  I checked and 18 leap
>> seconds did occur between the aforementioned dates.
>> I tried duplicating the test errors by building and testing
>> e2fsprogs-1.42.5 on a separate system with glibc-2.16.0 and
>> tzdata2012c installed.  In this case however, all the tests passed.
>> Why might these tests fail on one system but pass on another if the
>> versions of e2fsprogs, glibc, and tzdata are the same?
> That's a good question, but I don't have an answer.  Was the other
> system LFS?

I tried duplicating the errors on an Arch Linux system so there are
likely other system differences affecting the results.  As others have
subsequently pointed out, tzdata may be installed differently on Arch
vs. LFS.

More information about the lfs-support mailing list