[lfs-support] Help with GCC Compile Pass 1 errors

Richard Melville richard.melville69 at googlemail.com
Fri Aug 17 03:15:16 PDT 2012

Richard Melville wrote:
> >> Just went through this step in linux mint 32bit in vmware and found
> >>> no issues.
> >>>
> >>> That's because it's an intermittent bug.  I've just had the same
> >>> problem using Linux Mint Cinnamon 64 bit.  Sometimes the error
> >>> message appears and sometimes it doesn't.  If you look back through
> >>> the posts in the mailing list you will see that a number of people
> >>> have experienced this bug irrespective of host used.
> >> If the person does make again, does the system continue to build?
> >>
> >> If so, what is their MAKEFLAGS setting or are they using make -j 2 or
> >> 4 or 6 or 8?
> >>
> >> If not, do they have to remove the gcc build and gcc source
> >> directories, then reextract gcc, then extract gmp, mpfr, mpc in the
> >> gcc source tree then create gcc-build then reconfigure? And then does
> >> that make it work?
> > My error message was on pass 2; pass 1 worked as expected, but looking at
> > the posts it seems to make no difference; it appears to be random.
> >
> > I tried running make again but it failed at the same place -- MPC
> configure
> > couldn't find the MPFR libraries even though they were there.
> >
> > I've tried with, and without, make -j 2.
> >
> > It took me five attempts to get GCC to build;  I tried removing all
> traces
> > of GCC, reextracting, and trying again with no success.  On one occasion,
> > in desperation, I copied and pasted all the commands to remove the
> > possibility of an error introduced by me, but still no success. Finally,
> I
> > left the computer running and had a break.  I returned and tried again
> and
> > bingo -- GCC compiled.  I'm at a loss to explain why MPC configure
> finally
> > found the MPFR libraries when it couldn't find them before.
> >
> > To sum up -- whatever I did to try and make the compilation of GCC
> succeed
> > had absolutely no affect.  On the fifth attempt when it did succeed I had
> > removed all traces of GCC, reextracted, and run configure and make,
> exactly
> > as I had in some previous failed attempts.
> I have a lot of doubt that this build problem is random.  That just
> doesn't make sense in the absence of an intermittent HW error.  The way
> to isolate the problem is to create a short script of the commands used
> and run that, capturing the output to a log.  Posting the script and the
> appropriate part of the log (certainly not all of it) gives us a chance
> to review what you've done.
>    -- Bruce
> Hi Bruce

A little late getting back to you but, yes, should the error reappear then
I will create a log and send it to you.  The problem is that it seems to be
difficult to replicate.

On another subject, and a minor issue, the tzdata package in the
SVN-20120816 build instructions is version "e" but the package downloaded
from the LFS repository is version "c"

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120817/fd060b5f/attachment.html>

More information about the lfs-support mailing list