[lfs-support] Help with GCC Compile Pass 1 errors

Richard Melville richard.melville69 at googlemail.com
Mon Aug 13 03:02:27 PDT 2012

> Just went through this step in linux mint 32bit in vmware and found
> > no issues.
> >
> > That's because it's an intermittent bug.  I've just had the same
> > problem using Linux Mint Cinnamon 64 bit.  Sometimes the error
> > message appears and sometimes it doesn't.  If you look back through
> > the posts in the mailing list you will see that a number of people
> > have experienced this bug irrespective of host used.
> >
> > Richard
> Hello Richard,
> If the person does make again, does the system continue to build?
> If so, what is their MAKEFLAGS setting or are they using make -j 2 or
> 4 or 6 or 8?
> If not, do they have to remove the gcc build and gcc source
> directories, then reextract gcc, then extract gmp, mpfr, mpc in the
> gcc source tree then create gcc-build then reconfigure? And then does
> that make it work?
> Sincerely,
> William Harrington

Hi William

My error message was on pass 2; pass 1 worked as expected, but looking at
the posts it seems to make no difference; it appears to be random.

I tried running make again but it failed at the same place -- MPC configure
couldn't find the MPFR libraries even though they were there.

I've tried with, and without, make -j 2.

It took me five attempts to get GCC to build;  I tried removing all traces
of GCC, reextracting, and trying again with no success.  On one occasion,
in desperation, I copied and pasted all the commands to remove the
possibility of an error introduced by me, but still no success. Finally, I
left the computer running and had a break.  I returned and tried again and
bingo -- GCC compiled.  I'm at a loss to explain why MPC configure finally
found the MPFR libraries when it couldn't find them before.

To sum up -- whatever I did to try and make the compilation of GCC succeed
had absolutely no affect.  On the fifth attempt when it did succeed I had
removed all traces of GCC, reextracted, and run configure and make, exactly
as I had in some previous failed attempts.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120813/3a31a536/attachment.html>

More information about the lfs-support mailing list