[lfs-support] Help with GCC Compile Pass 1 errors

Keiran keiranamor at hotmail.com
Sun Aug 12 13:27:29 PDT 2012


On 12/08/12 21:22, Bruce Dubbs wrote:
> Keiran wrote:
>> Hello, I'm not sure if this is the correct place to mail with this
> Yes, this is the right list.
>
>> When trying to compile GCC at Chapter 5.5, I get this error, and no
>> amount of Googling has been able to solve it.
>>
>> configure: error: in `/mnt/lfs/sources/gcc-build/lto-plugin':
>> configure: error: C compiler cannot create executables
>>
>> Is this common? Is there an easy way to fix this?
> That tells me that gcc is not installed or binutils wasn't installed
> correctly.  What is the output of the script in Section iii - Host
> System Requirements?
>
>
>     -- Bruce
bash, version 4.2.24(1)-release
Binutils: (GNU Binutils for Ubuntu) 2.22
bison (GNU Bison) 2.5
bzip2,  Version 1.0.6, 6-Sept-2010.
Coreutils:  8.13
diff (GNU diffutils) 3.2
find (GNU findutils) 4.4.2
GNU Awk 3.1.8
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
(Ubuntu EGLIBC 2.15-0ubuntu10) 2.15
grep (GNU grep) 2.10
gzip 1.4
Linux version 3.2.0-29-generic-pae (buildd at roseapple) (gcc version 4.6.3 
(Ubuntu/Linaro 4.6.3-1ubuntu5) ) #46-Ubuntu SMP Fri Jul 27 17:25:43 UTC 2012
m4 (GNU M4) 1.4.16
GNU Make 3.81
patch 2.6.1
Perl version='5.14.2';
GNU sed version 4.2.1
tar (GNU tar) 1.26
Texinfo: makeinfo (GNU texinfo) 4.13
xz (XZ Utils) 5.1.0alpha
gcc compilation OK



More information about the lfs-support mailing list