[lfs-support] GCC-4.7.1-Pass 2 MPC configure fails

Baho Utot baho-utot at columbus.rr.com
Thu Aug 9 08:55:32 PDT 2012

On 08/09/2012 11:42 AM, Bruce Dubbs wrote:
> Richard Melville wrote:
>>>> Everything has built fine up to this stage and the sanity checks were OK.
>>>> MPFR and GMP have compiled OK with the libraries installed in .libs. I've
>>>> even checked to make sure that the MPFR libraries were 64 bit, and now
>>> I've
>>>> run out of ideas. I'd be really grateful for any help. I've tried
>>>> rebuilding GCC four times now with the same result.
>>> Are you sure you changed to the gcc-4.7.1 directory before
>>> tar -Jxf ../mpfr-3.1.1.tar.xz
>>> mv -v mpfr-3.1.1 mpfr
>>> tar -Jxf ../gmp-5.0.5.tar.xz
>>> mv -v gmp-5.0.5 gmp
>>> tar -zxf ../mpc-1.0.tar.gz
>>> mv -v mpc-1.0 mpc
>>>      -- Bruce
>>> Thanks for the really quick response Bruce -- much appreciated.
>> I'm 99.9% certain that I was in gcc-4.7.1; It's a routine -- untar and then
>> cd.  Even if I forgot once (which is unlikely) I don't believe that I would
>> have forgotten on all four occasions;  I always double check everything.
>> I've now attempted building gcc for the fifth time and it has built OK;
>> this is really weird. I've trawled the web and noticed that others have had
>> the same error message in MPC configure without finding a positive answer.
>>    Could it be a strange intermittent bug?  I'm not trying to shift
>> responsibility from my own actions, but I just can't see what I
>> did differently the fifth time around.
> One way to make sure you are using the exact instructions is to create a
> short script for the package.  For example:
> #!/bin/bash
> tar -xf package
> cd package
> configure ... 2>&1 | tee    pkg.log
> make          2>&1 | tee -a pkg.log
> make install  2>&1 | tee -a pkg.log
> Then it's reproducible and you can narrow down issues with the logs.
>     -- Bruce

you can use |& instead of 2>&1 |
it is the same if you are using bash 4.0+
make |& tee -a pkg.log

More information about the lfs-support mailing list