[lfs-support] GCC-4.7.1-Pass 2 MPC configure fails

Richard Melville richard.melville69 at googlemail.com
Thu Aug 9 04:05:48 PDT 2012

> Richard Melville wrote:
> > I realise that I'm building the dev edition, but my host is Linux Mint
> > Cinnamon 64 bit and the host requirements appeared to fit better. Also it
> > looked as though the dev edition was at a reasonably stable stage.
> >
> > I'm building a 64 bit edition on a 64 bit host (OS and hardware).
> >
> > The failure is:-
> >
> > checking for MPFR... no
> > configure: error: libmpfr not found or uses a different ABI (including
> > static vs shared).
> > make[1]: *** [configure-mpc] Error 1
> > make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'
> > make: *** [all] Error 2
> >
> > Everything has built fine up to this stage and the sanity checks were OK.
> > MPFR and GMP have compiled OK with the libraries installed in .libs. I've
> > even checked to make sure that the MPFR libraries were 64 bit, and now
> I've
> > run out of ideas. I'd be really grateful for any help. I've tried
> > rebuilding GCC four times now with the same result.
> Are you sure you changed to the gcc-4.7.1 directory before
> tar -Jxf ../mpfr-3.1.1.tar.xz
> mv -v mpfr-3.1.1 mpfr
> tar -Jxf ../gmp-5.0.5.tar.xz
> mv -v gmp-5.0.5 gmp
> tar -zxf ../mpc-1.0.tar.gz
> mv -v mpc-1.0 mpc
>    -- Bruce
> Thanks for the really quick response Bruce -- much appreciated.

I'm 99.9% certain that I was in gcc-4.7.1; It's a routine -- untar and then
cd.  Even if I forgot once (which is unlikely) I don't believe that I would
have forgotten on all four occasions;  I always double check everything.

I've now attempted building gcc for the fifth time and it has built OK;
this is really weird. I've trawled the web and noticed that others have had
the same error message in MPC configure without finding a positive answer.
 Could it be a strange intermittent bug?  I'm not trying to shift
responsibility from my own actions, but I just can't see what I
did differently the fifth time around.

Thanks again.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120809/5bc7f0d8/attachment.html>

More information about the lfs-support mailing list