[lfs-support] GCC-4.7.1-Pass 2 MPC configure fails

Richard Melville richard.melville69 at googlemail.com
Wed Aug 8 11:01:02 PDT 2012

I realise that I'm building the dev edition, but my host is Linux Mint
Cinnamon 64 bit and the host requirements appeared to fit better. Also it
looked as though the dev edition was at a reasonably stable stage.

I'm building a 64 bit edition on a 64 bit host (OS and hardware).

The failure is:-

checking for MPFR... no
configure: error: libmpfr not found or uses a different ABI (including
static vs shared).
make[1]: *** [configure-mpc] Error 1
make[1]: Leaving directory `/mnt/lfs/sources/gcc-build'
make: *** [all] Error 2

Everything has built fine up to this stage and the sanity checks were OK.
MPFR and GMP have compiled OK with the libraries installed in .libs. I've
even checked to make sure that the MPFR libraries were 64 bit, and now I've
run out of ideas. I'd be really grateful for any help. I've tried
rebuilding GCC four times now with the same result.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120808/bc6b32b2/attachment.html>

More information about the lfs-support mailing list