[lfs-support] PS1 for user lfs

Bruce Dubbs bruce.dubbs at gmail.com
Fri Apr 20 15:32:26 PDT 2012

Philippe Delavalade wrote:
> Le vendredi 20 avril à 23:51, Bruce Dubbs a écrit :
> [...]
>> Everything except PS1 seems OK.
> it's to complicated for me :-)
>> Did you do 4.3:  `su - lfs` 
> Yes, sure ! I tried three times ; the first time, I thought I forgot some
> thing ; so I ran `userdel` and `groupdel` and began again, this two times
> but the result is always the same.
>> The dash is needed.  PS1 is not normally set when 
>> starting a login shell.  We set it explicitly.  In a non-login shell, it needs 
>> to be reset every time, usually by setting it in ~/.bashrc.
> yes, that's what I do for the other users but with user lfs, I follow
> always exactly the book and use cut/paste for commands to avoid any typo.

Sure, but sometimes inadvertent errors are made.

> While mailing on the list with you, I configure, compiled and intalled
> binutils and gcc (pass 1) without any problem.

Yes, a different PS1 prompt should not give you any problem.  I was just trying 
to help you figure out this minor discrepancy.

What happens if you just `export PS1='\u:\w\$ '`

   -- Bruce

More information about the lfs-support mailing list