[lfs-support] problem with section 6.9 of LFS 7.1

Charles Wood wood.charles.h at gmail.com
Fri Apr 6 17:38:20 PDT 2012


Installing glibc-2.14.1

I am a student and am doing Linux From Scratch as a class project. I am
working on section 6.9, installing glibc-2.14.1. I have made sure I am
entering all the commands correctly. When I perform "make install" it runs
for quite awhile but gives an error at the end. Here is a copy of the text:

test ! -x /sources/glibc-build/elf/ldconfig || LC_ALL=C LANGUAGE=C \
  /sources/glibc-build/elf/ldconfig  \
                   /lib64 /usr/lib64
CC="gcc" /usr/bin/perl scripts/test-installation.pl /sources/glibc-build/
gcc: error: /tmp/test-prg5634: No such file or directory
Execution of gcc failed!
The script has found some problems with your installation!
Please read the FAQ and the README file and check the following:
- Did you change the gcc specs file (necessary after upgrading from
  Linux libc5)?
- Are there any symbolic links of the form libXXX.so to old libraries?
  Links like libm.so -> libm.so.5 (where libm.so.5 is an old library) are
wrong,
  libm.so should point to the newly installed glibc file - and there should
be
  only one such link (check e.g. /lib and /usr/lib)
You should restart this script from your build directory after you've
fixed all problems!
Btw. the script doesn't work if you're installing GNU libc not as your
primary library!
make[1]: *** [install] Error 1
make[1]: Leaving directory `/sources/glibc-2.14.1'
make: *** [install] Error 2

I have double-checked and entered the sed commands concerning the
test-installation.pl script. I have checked the gcc specs file and all the
/tools prefixes are there and correct. I have searched and searched the LFS
site and found no help. Any ideas? Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20120406/b4021738/attachment.html>


More information about the lfs-support mailing list