[lfs-support] Can't install irssi

Andrew Benton andy at benton.eu.com
Wed Apr 4 09:22:06 PDT 2012


On Wed, 04 Apr 2012 14:09:46 +0100
gmspro <gmspro at yahoo.com> wrote:

> I have install glib and pkg-config following th blfs doc
> 
> cd irssi-0.8.15
> 
> ./configure
> 
> checking for pkg-config... /usr/bin/pkg-config
> checking pkg-config is at least version 0.7... yes
> checking for GLIB - version >= 2.6.0... Package libpcre was not found in the pkg-config search path.
> Perhaps you should add the directory containing `libpcre.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'libpcre', required by 'GLib', not found
> no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link. See the file config.log for the
> *** exact error that occured. This usually means GLIB is incorrectly installed.
> *** trying without -lgmodule
> checking for pkg-config... (cached) /usr/bin/pkg-config
> checking pkg-config is at least version 0.7... yes
> checking for GLIB - version >= 2.6.0... Package libpcre was not found in the pkg-config search path.
> Perhaps you should add the directory containing `libpcre.pc'
> to the PKG_CONFIG_PATH environment variable
> Package 'libpcre', required by 'GLib', not found
> no
> *** Could not run GLIB test program, checking why...
> *** The test program failed to compile or link. See the file config.log for the
> *** exact error that occured. This usually means GLIB is incorrectly installed.
> 
> *** If you don't have GLIB, you can get it from ftp://ftp.gtk.org/pub/glib/
> *** We recommend you get the latest stable GLIB 2 version.
> *** Compile and install it, and make sure pkg-config finds it,
> *** by adding the path where the .pc file is located to PKG_CONFIG_PATH
> 
> configure: error: GLIB is required to build irssi.
> 
> What should i do?

Several things.
Firstly, as irssi is not part of LFS you should really be asking these
sorts of questions on the BLFS-Support mailing list.

The error above says you've not installed PCRE. Try installing it
http://www.linuxfromscratch.org/blfs/view/svn/general/pcre.html
and then install glib again
http://www.linuxfromscratch.org/blfs/view/svn/general/glib2.html

Lastly, the error message above says that there are more details in
irssi-0.8.15/config.log. What does it say in relation to pcre and glib?

Andy



More information about the lfs-support mailing list