Help Please: 5.17 Coreutils compilation terminated. (LFS 6.8)

Ken Moffat ken at
Tue Mar 15 12:33:02 PDT 2011

On Tue, Mar 15, 2011 at 11:38:03AM -0700, bsquared wrote:
> > I tried to recreate the directory per ch. 5.10 instructions and it
> > failed complaining about gmp.h also. However, I don't know if the
> > toolchain adjustment has any effect.  I may have to wipe /tools and
> > start over.
> >
> I was able to recreate the gcc-build directory, and the build still
> failed with the same error.
> Any ideas are appreciated.
 Your first post showed that configure had referenced libselinux as
well as libgmp.  I would expect coreutils' configure script to
decide that libgmp was NOT present.

 Please read the penultimate 3 paragraphs of section 5.2, "Toolchain
Technical Notes".  You should have changed the specs file in section
5.8 so that the linker in /tools/lib is used.  Then, in the second
pass of binutils you should have passed --with-lib-path=/tools/lib
to avoid using the host's linker.

 There are also a host of things that we do in pass 2 of gcc, but my
guess is that you missed something in the second pass of binutils.

 Alternatively, using an existing source or -build directory left
over from pass 1 would probably cause this sort of problem.

das eine Mal als Tragödie, das andere Mal als Farce

More information about the lfs-support mailing list