gcc test failures

Alex Bosworth bworthalex at yahoo.com
Sun Mar 13 12:50:43 PDT 2011

----- Original Message -----
From: "Bruce Dubbs" <bruce.dubbs at gmail.com>
To: "LFS Support List" <lfs-support at linuxfromscratch.org>
Sent: Sunday, March 13, 2011 10:47:47 AM
Subject: Re: gcc test failures

Alex Bosworth wrote:
> Here's the synopsis:
> Been trying to compile LFS (from the latest svn version) on my laptop, I have 
> tried four times so far (please note I'm making use of  JHLAFS).  During all the 
> four builds, gcc tests don't seem to be satisfactory as the number of unexpected 
> failures is too high and the number of expected passes is too low. I have tried 
> changing the CFLAGS and tried to be conservative but, the result seems to be the 
> same. The fourth time I chose to run tests both for the tools and the final 
> system. As I can see tests for all other packages are successful (All # tests 
> were successful) except for gcc ! The CFLAGS I used for the fourth build are 
> "-O3 -pipe -msse -msse2 -mmmx -march=native -mtune=native". The processor is an 
> Intel Penitum4 Mobile.
> The only deviations from the SVN book are m4 (using 1.4.16),  mpc (using 0.9), 
> less (using 446).
> Here's the "grep -A7 Summ" output:

>                 === g++ Summary ===
> # of expected passes            6
> # of unexpected failures        3543

> >I agree that this number of failures is way too high.  Since you are 
> >using jhalfs, the problem is not a typo.  I would suspect a hardware 
> >problem of some kind.  Do you have enough free memory or diskspace?  Can 
> >you duplicate the problme on another system?

> >   -- Bruce

Thanks for the reply.

I don't think this is a hardware problem as none of the other packages fail their tests and I don't encounter any crashes or errors during normal use. As far the disk space and memory are concerned I do have about 768MB of RAM with 1GB swap with several GBs of free disk space. I have compiled LFS/BLFS a few times before this and I never had any problems then. As I'm using JHALFS, it includes gcc and a few other packages from custom optimizations. So it has nothing to do with the custom optimizations at least not directly.

Unfortunately I don't have similar hardware available to me now (I do have a desktop with a quad core X86_64, I don't think I would encounter this problem on that machine).



More information about the lfs-support mailing list