gcc test failures

Bruce Dubbs bruce.dubbs at gmail.com
Sun Mar 13 09:47:47 PDT 2011

Alex Bosworth wrote:
> Here's the synopsis:
> Been trying to compile LFS (from the latest svn version) on my laptop, I have 
> tried four times so far (please note I'm making use of  JHLAFS).  During all the 
> four builds, gcc tests don't seem to be satisfactory as the number of unexpected 
> failures is too high and the number of expected passes is too low. I have tried 
> changing the CFLAGS and tried to be conservative but, the result seems to be the 
> same. The fourth time I chose to run tests both for the tools and the final 
> system. As I can see tests for all other packages are successful (All # tests 
> were successful) except for gcc ! The CFLAGS I used for the fourth build are 
> "-O3 -pipe -msse -msse2 -mmmx -march=native -mtune=native". The processor is an 
> Intel Penitum4 Mobile.
> The only deviations from the SVN book are m4 (using 1.4.16),  mpc (using 0.9), 
> less (using 446).
> Here's the "grep -A7 Summ" output:

>                 === g++ Summary ===
> # of expected passes            6
> # of unexpected failures        3543

I agree that this number of failures is way too high.  Since you are 
using jhalfs, the problem is not a typo.  I would suspect a hardware 
problem of some kind.  Do you have enough free memory or diskspace?  Can 
you duplicate the problme on another system?

   -- Bruce

More information about the lfs-support mailing list