GRUB problems

JAMC60 jamc60 at gmail.com
Mon Mar 7 12:35:18 PST 2011


Hi.
I'm trying to install lfs-6.8 via ssh in a somehow old PC. This is the
output of lspci

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 746 Host (rev 10)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SG86C202
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media
IO] (rev 25)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97
Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
(rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:0c.0 Ethernet controller: Intel Corporation 82557/8/9 Ethernet Pro 100
(rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5200]
(rev a1)

Processor is:

processor    : 0
vendor_id    : AuthenticAMD
cpu family    : 6
model        : 8
model name    : AMD Athlon(tm) XP 2000+
stepping    : 1
cpu MHz        : 1674.800
cache size    : 256 KB
fdiv_bug    : no
hlt_bug        : no
f00f_bug    : no
coma_bug    : no
fpu        : yes
fpu_exception    : yes
cpuid level    : 1
wp        : yes
flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up ts
bogomips    : 3351.22
clflush size    : 32

All seems to be ok but the last step: Using grub to set up the boot process
The output of device.map is:

(fd0)    /dev/fd0
(hd0)    /dev/hda

So, the next step is:
grub-install /dev/hda
but that command fail and the prompter doesn't come back. Only populate
/boot/grub. It Seems like grub2 can't see my linux kernel file. The contents
of /boot are:
-rw-r--r-- 1 root root   66302 mar  7 20:54 config-2.6.37
drwxr-xr-x 3 root root    5120 mar  7 21:04 grub
drwx------ 2 root root   12288 mar  6 10:15 lost+found
-rw-r--r-- 1 root root 1675246 mar  7 20:53 System.map-2.6.37
-rw-r--r-- 1 root root 3377280 mar  7 20:53 vmlinux-2.6.37-lfs-6.8

I have the following partition table:
hda1   boot
hda2   root
hda5   home
hda6   swap

Can someone help me?

Thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20110307/b88bd941/attachment.html>


More information about the lfs-support mailing list