LFS-svn chap 6.7 (gcc: No such file or directory)

Martin Zajíc <ZAJCA> zajcaa at gmail.com
Wed Sep 8 02:56:23 PDT 2010


>> It's not 100% but for now all comands working I checked it. Only
>> problem is that GCC (all gcc binaries) is bad linked, but only GCC
>> nothink else.
>>
>
>  So, since this is a school project, all *you* have to do is to work
> out what you did wrongly, or missed.  Assuming your controlling
> script invokes gcc pass 2 (I haven't checked), it looks as if you
> have an uncaught error there, or else that you omitted the install.
>
>  What Simon said about errors is *very* pertinent - my own
> script to build xorg failed this week - appeared to complete
> successfully in under 5 minutes.  We all make errors, and
> learning how to find them is the important thing.
>
>  In my case, the error was obvious - I'd had a similar problem
> in the past, and attempted to trap future errors by testing
> '$?'.  Unfortunately, I'd put this immediately after
>  do-something &&
> so the trap was never executed.
>
>  If you aren't already creating logs (particularly, stderr), you
> might want to, so that you can read any error messages.
>
So i've rewrite gcc pass2 with last svn and it's working.

I have another question about testing error.
I try to make LOG with '{....} 2>&1 | tee $BUILD_DIR/LOG_$PROGRAM.log'
but when I did it how can I test it for errors, becouse '$?' not
working even if the script inside ending with 'exit 1'.

--
Martin Zajíc
E-mail: zajcaa at gmail.com
Jabber: zajcaa at gmail.com
Twitter: http://twitter.com/zajca



More information about the lfs-support mailing list