GCC Pass 2 Error - LFS-svn

Simon Geard delgarde at ihug.co.nz
Fri Sep 3 02:35:49 PDT 2010


On Fri, 2010-09-03 at 00:15 +0200, Martin Zajíc wrote:
> configure: error: Building GCC requires GMP 4.2+, MPFR 2.3.1+ and MPC 0.8.0+.

See comments below...

> /mnt/lfs/scripts/chap5/gccP2: line 140: --disable-libstdcxx-pch:
> command not found

That one looks like a typo - it's trying to run one of the parameters to
configure as a separate command, which means you've probably missed a
'\' at the end of a line, or something like that.


> I have all folders on right place.
> .
> ├── gcc-4.5.1
> ├── gcc-4.5.1-BUILD
> ├── gmp
> ├── mpc
> └── mpfr
> 

No, you don't. Remember, *all* instructions for a package are assumed to
be run from inside the extracted directory for that package, which in
this case is gcc-4.5.1. The gmp, mpc, and mpfr directories should be
inside that one, as they will be if you're in that directory when you
extract them.

Simon.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: This is a digitally signed message part
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100903/d6be9ff4/attachment.sig>


More information about the lfs-support mailing list