problem building at step 5.5.1

robert mullinrobert at gmail.com
Wed Nov 24 15:05:19 PST 2010


Arrived at step 5.5.1, Installation of Cross GCC.

I am using "LFS-BOOK-6.7-HTML/chapter05/gcc-pass1.html"

I have unpacked the mpfr, gmp, and mpc tarballs and renamed the 
resulting directories as instructed

I created /mnt/lfs/sources/gcc-build directory
then, cd /mnt/lfs/sources/gcc-build
I issued the "prepare for compilation" configure command (copy and paste)

when I issue "make" command, I receive the following error message:

++++++++++++++++++++
checking for the correct version of gmp.h... no
configure: error: Building GCC requires GMP 4.2+, MPFR 2.3.1+ and MPC 
0.8.0+. Try the --with-gmp, --with-mpfr and/or --with-mpc options to 
specify their locations.
++++++++++++++++++++

I don't understand the syntax of --with-gmp ... 
--with-gmp=/mnt/lfs/sources/gmp????

Thanks in advance for your help.




More information about the lfs-support mailing list