Help: but there didn't have "Bison-1.875" and "Gawk-3.0"

Chris Staub chris at beaker67.com
Sun Mar 28 10:15:25 PDT 2010


On 03/28/2010 10:02 AM, AOL wrote:
> Good day. Please excuse my English.
> I am trying establish LFS, my host-system is gNewSense.
> Apparently it's enough (gNewSense), but there didn't have "Bison-1.875"
> and "Gawk-3.0", required in "Chapter vii. Host System Requirements,
> Linux From Scratch - Version 6.6 "
> Synaptic Package Manager offer: bison(1.2.3.dfsg-5), bison++(1.21.11-3),
> bison-1.35(1.35-4.1), bisonc++(2.4.0-1), bison-doc(1.2.3-2).
> I downloaded bisonc++(2.4.0-1), or needed other from above named?
> Instead Gawk-3.0 there are: dpkg-awk(1.0.1.0.0.1),
> gawk(1.3.1.6.dfsg-0ubuntu1), gawk-doc(3.1.6-0ubuntu1),
> , mawk(1.3.3-11ubuntu2).
> I downloaded gawk(1.3.1.6.dfsg-0ubuntu1) and mawk1.3.3-11ubuntu2), or
> needed other from above named?
> I am fully oak in computers.
> I can't be in dialogue, but I'll read everything carefully.
> Sincerely, fuf.
>

Looks like you're just confused about the book's mention of those 
version numbers. Keep in mind that on the Host System Requirements page, 
all the package versions are the *minimum* - you must have that version 
or newer. So, you just need to have any version of Bison 1.875 or newer, 
and Gawk 3.0 or later. I'm sure that you probably just need to "apt-get 
install bison" and "apt-get install gawk" and that should install the 
latest.



More information about the lfs-support mailing list