Help: but there didn't have "Bison-1.875" and "Gawk-3.0"

Andrew Benton b3nton at gmail.com
Sun Mar 28 07:28:10 PDT 2010


On 28/03/10 15:02, AOL wrote:
> Good day. Please excuse my English.
> I am trying establish LFS, my host-system is gNewSense.
> Apparently it's enough (gNewSense), but there didn't have "Bison-1.875"
> and "Gawk-3.0", required in "Chapter vii. Host System Requirements,
> Linux From Scratch - Version 6.6 "
> Synaptic Package Manager offer: bison(1.2.3.dfsg-5), bison++(1.21.11-3),
> bison-1.35(1.35-4.1), bisonc++(2.4.0-1), bison-doc(1.2.3-2).
> I downloaded bisonc++(2.4.0-1), or needed other from above named?
> Instead Gawk-3.0 there are: dpkg-awk(1.0.1.0.0.1),
> gawk(1.3.1.6.dfsg-0ubuntu1), gawk-doc(3.1.6-0ubuntu1),
> , mawk(1.3.3-11ubuntu2).
> I downloaded gawk(1.3.1.6.dfsg-0ubuntu1) and mawk1.3.3-11ubuntu2), or
> needed other from above named?
> I am fully oak in computers.
> I can't be in dialogue, but I'll read everything carefully.
> Sincerely, fuf.
>
If you can't install gawk and bison using your distro's package manager it is
possible to install them from the source if you compile them as user lfs and
install them into /tools. That's what I do when I install from Ubunut. first gawk

tar xf gawk-3.1.7.tar.*
cd gawk-3.1.7
bash configure --prefix=/tools
make SHELL=/bin/bash # ubuntu uses dash for /bin/bash
make SHELL=/bin/bash install
cd ..
rm -rf gawk-3.1.7

Then m4. I think bison needs m4?

tar xf m4-1.4.14
cd m4-1.4.14
bash configure --prefix=/tools
make make install
cd ..
rm -rf m4-1.4.14

Then bison

tar xf bison-2.4.1
cd bison-2.4.1
bash configure --prefix=/tools
make make install
cd ..
rm -rf bison-2.4.1

You might need flex too

tar xf flex-2.5.35.tar.*
cd flex-2.5.35
sed -i '/ios/a \  "#include <cstdio>",' skel.c # sed is easier than patching
bash configure --prefix=/tools
make $THREADED
make install
cd ..
rm -rf flex-2.5.35
ln -s libfl.a /tools/lib/libl.a
cat > /tools/bin/lex << "EOF"
#!/tools/bin/bash
exec /tools/bin/flex -l "$@"
EOF
chmod 755 /tools/bin/lex

Then start chapter 5, binutils and so on. Follow the book and reinstall
gawk and m4 just to be sure. Hope that hasn't confused you. It makes life
easier for me as it means I don't need to mess about with Ubunut's package
manager. I can just boot from the cd and go.

Andy



More information about the lfs-support mailing list