grub2: error: fiel not found

Bruce Dubbs bruce.dubbs at
Thu Mar 25 13:22:53 PDT 2010

Ken Moffat wrote:

>> If /dev/sda15 is your /boot partition, it should then find the grub
>> modules in grub/.

>  My reading was that it didn't.  If you look at my original post I had
> |# sda7 LFS-6.6-rc2 pure64
> |menuentry "LFS-6.6-rc2 pure64 2.6.33 (sda7)" {
> |       insmod ext2
> |       set root=(hd0,15)
> |       search --no-floppy --fs-uuid --set 5a1327f4-48e3-4bce-afe3-67b388437720
> |       linux   /vmlinuz-2.6.33-sda7 root=/dev/sda7
> video=radeonfb:1024x768-16 at 70 ro
> |}

My understanding is that should have worked.  Of course, the search line 
is not used by LFS.  I'd remove it just for clarity.

>  Is that *not* what the book suggests for root= in my case ?  In any
> case, grub didn't get that far, it was in the rescue shell, not the regular
>  grub shell.

What happens if you move the set root=(hd0,15) outside the menuentry?

>  And it was the *prefix* hd(0,15)/boot/grub that was the problem - as
> I said, I've still no idea where prefix is set.

Me either.

>  /me scratches his head a lot, and rereads section 8.4.  All I can see is
> 'default root setting - guessed' and the note beneath it, telling me the
> default root will be used if a 'set root' instruction is not found in
> grub.cfg.  I can't see any reference to *how* to alter the default root,
> but since it showed up as root=hd(0,15) when I ran 'set' in the rescue
> shell, I believe it was already correct.

I'm not sure what you mean by rescue shell.  Can you elaborate?

>  Also, isn't 'insmod ext2' going to be redundant in grub.cfg on an ext2+
> filesystem ?  If grub can't read an ext2fs, it won't be able to read
> grub.cfg.

Yes, that makes sense.  I don't know if that is necessary.  I'd think 
that ext2 was built into the image loaded at sectors 1-62, where sector 
0 is the MBR.

Are you using grub-1.98?

   -- Bruce

More information about the lfs-support mailing list