Reposted my config

Bruce Dubbs bruce.dubbs at gmail.com
Tue Mar 16 23:32:00 PDT 2010


brown wrap wrote:
> 
> config file:
> 
> http://pastebin.com/TVa6pvbx

This is what I have:

$ grep -n USB config-2.6.32.7-lfs66rc1 |grep =
1594:CONFIG_USB_HID=y
1596:CONFIG_USB_HIDDEV=y
1635:CONFIG_USB_SUPPORT=y
1636:CONFIG_USB_ARCH_HAS_HCD=y
1637:CONFIG_USB_ARCH_HAS_OHCI=y
1638:CONFIG_USB_ARCH_HAS_EHCI=y
1639:CONFIG_USB=y
1640:CONFIG_USB_DEBUG=y
1641:CONFIG_USB_ANNOUNCE_NEW_DEVICES=y
1646:CONFIG_USB_DEVICEFS=y
1649:CONFIG_USB_SUSPEND=y
1651:CONFIG_USB_MON=y
1660:CONFIG_USB_EHCI_HCD=y
1667:CONFIG_USB_OHCI_HCD=y
1670:CONFIG_USB_OHCI_LITTLE_ENDIAN=y
1671:CONFIG_USB_UHCI_HCD=y
1681:CONFIG_USB_PRINTER=y
1692:CONFIG_USB_STORAGE=y
1705:CONFIG_USB_LIBUSUAL=y

$ grep -n KEY config-2.6.32.7-lfs66rc1 |grep =
1050:CONFIG_INPUT_KEYBOARD=y
1052:CONFIG_KEYBOARD_ATKBD=y
1609:CONFIG_HID_EZKEY=y
2174:CONFIG_KEYS=y
2175:CONFIG_KEYS_DEBUG_PROC_KEYS=y

I don't see anything that odd about your config.

I really think you have a HW problem:
[    4.143348] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    4.148482]   alloc irq_desc for 20 on node -1
[    4.148484]   alloc kstat_irqs on node -1
...
[   19.994054] usb 1-2: device not accepting address 2, error -110
etc

Mine are:
[    0.000999]   alloc irq_desc for 24 on cpu 0 node 0
[    0.000999]   alloc kstat_irqs on cpu 0 node 0
...
[    2.367994] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    2.368808] drivers/usb/core/inode.c: creating file 'devices'
[    2.368811] drivers/usb/core/inode.c: creating file '001'

   -- Bruce






More information about the lfs-support mailing list