v6.6 section 6.10, Re-adjusting the Toolchain

David Gay davidwgay at hotmail.com
Tue Mar 16 08:47:05 PDT 2010

> Date: Tue, 16 Mar 2010 02:37:52 -0400
> Subject: Re: v6.6 section 6.10, Re-adjusting the Toolchain
> From: stosss at gmail.com
> To: lfs-support at linuxfromscratch.org
>>>From the Book, the 3rd block of commands are:
>> --------------------------------------------------
>> echo 'main(){}'> dummy.c
>> cc dummy.c -v -Wl,--verbose &> dummy.log
>> readelf -l a.out | grep ': /lib'
>> --------------------------------------------------
> The only thing that I see that is different with your code and the
> book's code is in the first line:
> Yours
> echo 'main(){}'> dummy.c # no space '>
> Book's
> echo 'main(){}'> dummy.c # space '>
> --

Thanks for the quick response.  However, I tried the above both with and without the space, and still get the same issue.  It's interesting that in my email the space is missing, as I simply did a copy & paste  directly from the book.

Looking at the dummy.log file, I wonder if the following line indicates that I mistyped/did  something in an earlier step:

cc: unrecognized option '-mtune=generic'

Any idea which step may have introduced this problem?

Thanks again for any help.

Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.

More information about the lfs-support mailing list