Configuring the network script (Chapter 7) with Debian Lenny as host

Trent Shea trentshea at
Sun Mar 14 15:48:07 PDT 2010

On Sunday 14 March 2010 16:19:30 Bruce Dubbs wrote:
> Trent Shea wrote:
> > I just ran a jhalfs build for lfs-6.6 and got hung up in chapter 7's
> > "configuring the network script" at the for command. There are no errors
> > reported, but no rule created either. I worked around this by booting to
> > the new system and running the for command again.
> > 
> > If someone can confirm this it may be worth a note in the errata.
> I can't confirm.  What kind of nic do you have?  For me, I have
> # PCI device 0x8086:0x10de (e1000e)
> SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
> ATTR{address}=="00:25:64:38:ec:dd", ATTR{type}=="1", KERNEL=="eth*",
> NAME="eth0"

The following is what I get when I run run the commands after booting into the 
lfs system:

# PCI device 0x1039:0x0900 (sis900)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", 
ATTR{address}=="00:01:6c:35:82:7a", ATTR{dev_id}=="0x0", ATTR{type}=="1", 
KERNEL=="eth*", NAME="eth0"

# PCI device 0x168c:0x0013 (ath5k)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", 
ATTR{address}=="00:18:e7:05:6d:ca", ATTR{dev_id}=="0x0", ATTR{type}=="1", 
KERNEL=="wlan*", NAME="wlan0"

Everything works for me from an ubuntu or lfs host. /sys on debian stable is a 
bit different though, /sys/class/net/eth0 is a folder rather than a link. The 
debian kernel was a 2.6.26, I think.

> I did test 6.6 with jhalfs before release.  That for statement has been
> in the book since May 2008, so its been working for quite a while.
It's always worked for me too, but I haven't built on debian in ages...

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the lfs-support mailing list