Problem installing the "nouveau" driver

alupu at verizon.net alupu at verizon.net
Tue Jun 29 08:25:08 PDT 2010


On Jun 29, 07:40:18 AM, Simon wrote:

> What exactly is your problem with running in the high-res mode?
> If it's just that the font size is too small, I'd have to repeat
> Stephane's suggestion of selecting a different console font
> (somewhere in the kernel config, I think).

I'm confused.  So before we go to the _exact_ steps of
how to set a font in kernel which would take effect after
"nouveau" is up, I want to establish a common ground.

With "nouveau", my boot-up goes through these basic steps:

1. The original/"regular" console sequence (80x25)
2. Nouveau is loaded by UDEV
3. At this point, the console goes blank for a sec or so.
 The preceding messages are wiped out.
4. The remainder of the boot-up sequence proceeds and stays
in 240x67 all the way to the prompt (and beyond).

5. I can never change the 240x67 resolution of the console
text mode.

QUESTION
Does anybody have/see a different behavior?

NOTE
I can imagine people going directly to X (graphics mode).
In that case, to stay with me on step 4 above, just come
"down" in console text mode for a moment or so
(Ctrl-Alt-Backspace or whatever) and check the ensuing
text resolution.
BTW, I'm interesting in the answer to my question above
more than in comments to this note :)

BTW, the _exact_ steps of how to set a font in kernel which
would take effect after "nouveau" is up, will be highly
appreciated.

Thanks,
-- Alex



More information about the lfs-support mailing list