Can't compile hsfmodem driver in LFS 6.6.

rhubarbpie at poetworld.net rhubarbpie at poetworld.net
Tue Jun 22 18:27:53 PDT 2010


Greetings,

I'm unable to compile an hsfmodem in LFS 6.6.  I realize a modem isn't 
exactly a state-of-the-art internet connection, but I do use  my modem 
occasionally and the problem bugs me.  The problem is I can compile the 
modem driver in LFS 6.3 with the 2.6.26 kernel but can't compile the 
driver under the 2.6.32.8 LFS 6.6 kernel.

Unfortunately, linuxant support has been less than helpful.  Apparently 
they view the problem as "incorrectly behaving" low-level OS tools on my 
box.  Huh?  I realize I'm not incapable of error, but I've run LFS and 
their driver on my box for several years.  Other than my linuxant 
problem everything seems to be working quite well.  What might 
incorrectly behaving low-level OS tools on my box mean?  What should I 
check.

One reason I suspect their driver is the problem is they recently 
released a new driver (hsfmodem-7.80.02.06full) for 2.6.32.8.  It 
flat-out doesn't compile.  Their old driver (hsfmodem-7.68.00.12full) 
doesn't compile on my LFS 6.6 build, and produces the message "ERROR: 
Module build failed!" and a log file.  However, their 
hsfmodem-7.80.02.06full) version produces no such message or log file 
although it's in their script to do so.

So, perhaps the problem IS on my side, but everything else seems to be 
working quite well.  I'm at a loss.  What should I check?  What 
information should I provide?



More information about the lfs-support mailing list