Problem installing the "nouveau" driver

Andrew Benton b3nton at gmail.com
Fri Jun 18 09:35:55 PDT 2010


On 18/06/10 02:29, alupu at verizon.net wrote:
> Hello,
>
> i686-pc-linux-gnu, 2.6.34, udev-156, (B)LFS
> NVidia GeForce 8300GS
>

I think the 8000 series needs extra firmware. My wife's computer has a 
8400GS which needs nv86.ctxprog and nv86.ctxvals. I compile them into 
the kernel with

CONFIG_FW_LOADER=y
CONFIG_FIRMWARE_IN_KERNEL=y
CONFIG_EXTRA_FIRMWARE="nouveau/nv86.ctxprog nouveau/nv86.ctxvals"

I don't remember where I downloaded them from. I suspect it was
http://people.freedesktop.org/~pq/nouveau-drm/

> A few (hopefully) relevant DETAILS:
>
> 1. In '.config' I have
> Device Drivers > Staging drivers > <M> Nouveau (nVidia) cards
> Note: It can only be <M>, <*> is not possible.
>
It must be that it depends upon something else that you have configured 
as a module. I look after 3 computers that use the nouveau driver built 
into monolithic kernels

> 2. On the only cyberpage I found helpful,
> at <en.gentoo-wiki.com/wiki/Nouveau>,
> they talk about
> Device Drivers > Graphics support >
> <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support),
> while my system accepts this parameter only as <M>.
>
> I know I'll have the work cut up for me, once I start thinking about Xorg,
> what with creating a "nouveau_drv.so", but for the time being all I want
> is to eliminate the blank screen on boot-up to command mode so
> I can have a fighting chance.
>
> I'd appreciate any helpful comments.
> Thanks,
> -- Alex
>
Try compiling the firmware into the kernel. If that doesn't work we'll 
need to see your kernel config. Perhaps you could put it up on pastebin 
and post a link to it?

Andy



More information about the lfs-support mailing list