AW: AW: Cannot execute grub-install

Michael Vahl mvahlbm at bib.h-brs.de
Fri Jun 18 09:13:51 PDT 2010


Michael Vahl wrote:
>>> Michael Vahl wrote:
>>> Hey y'all,
>>>
>>> i've recently passed all prior steps of chapter 8.4.2 (LFS 6.6). But
now,
>>> without any error messages, I'm not able to execute "grub-install
>>> --grub-setup=/bin/true /dev/sda". grub-install can be found and sda is
> the
>>> system's hdd but the system doesn't confirm the command. Nothing
happens.
>>> The only thing I can do is "Ctrl+C". Does someone else have the same
> problem
>>> or can give me a hint? 
> 
>> Do you have /dev poopulated according to section 6.2.2?
> 
>> What grub-install does though is copy files to /boot/grub.  Is that 
>> happening?

> Thanks for your reply......
> 
> Unfortunately /dev is populated correctly and no grub-config files are
> copied to /boot/grub: possibility one as well as possibility two I've
> already considered.
> 
> Any other suggestions?

The way I would approach it would be to look at the source and see where 
it is hanging.  grub-install is a shell script.

A very simple first test would be to ensure `grub-install --help` works.

   -- Bruce

--------------------------------------------


Thanks for your reply.....

After a step-by-step execution of grub-install, I determined that the script
grub-mkconfig_lib in /usr/lib/grub/ (line 35 of grub-install) doesn't have
the appropriate filemode (changed to 755). After modification an execution
of grub-mkconfig_lib caused the following stdout: /tools/bin/bash: warning:
setlocale: LC_ALL: cannot change locale (..). Anyway, I guess that the
mistake was done far earlier...

Further suggestions??




More information about the lfs-support mailing list