LFS 6.6 Chapter 8.1 Can't "make" new kernel

Ken Moffat zarniwhoop73 at googlemail.com
Fri Jun 18 10:18:01 PDT 2010

On 18 June 2010 17:02, Franz L. Kuhlmann <f_kuhlmann at freenet.de> wrote:
> After having installed Ubuntu 9.10 I worked quite happily through the book
> up to section 8.1.
> However, after executing make oldconfig (since I felt to be safe with my
> rather ordinary desktop PC),

 I hope you were running a recent kernel at this point, and copied its config
to .config before you ran 'make oldconfig' ?

> ....
>  *
>  * Random Number Generation
>  *
>   Pseudo Random Number Generation for Cryptographic modules
> (CRYPTO_ANSI_CPRNG) [N/m/y/?] n
> #
> #
>  configuration written to .config
> #
> I ran into trouble:
> root:/sources/linux- make
> scripts/kconfig/conf -s arch/x86/Kconfig
> /bin/sh: defaultingto080480b8: command not found
> make: *** [include/config/kernel.release] Error 127
> root:/sources/linux- vim README
> root:/sources/linux-
> In the archives of the past 3/4 months, I couldn't find anything which might
> give me a hint to what the problem is.
> Is there anybody around, pls, to put me straight.
> --

That output is a bit mixed up, as well as missing whitespace,
which makes it rather hard to work out what the actual error is
[ defaulting to 080480b8 from ld is just a warning ].

Possibly, it's saying that /bin/sh is missing or broken.
Please check your /bin/sh symlink.  If it exists, try opening
a new shell with /bin/sh and see what error you get.

If that isn't the problem, please try make V=1 to try to get
some more output to point to what is failing/missing.

After tragedy, and farce, "OMG poneys!"

More information about the lfs-support mailing list