LFS6.4 step 5.17 compiling coreutils-6.12 error

Bruce Dubbs bruce.dubbs at gmail.com
Fri Jan 29 08:34:19 PST 2010


haiye1018 wrote:
> Thank everyone!!!
> I have fixed it.
> Coreutils whose version is greater than 6.0 needs selinux,  which can be see from source file:
> #include <selinux/selinux.h> or / and 
> #include <selinux/context.h>

Don't top post.  Trim what isn't needed.  You are talking to several 
hundred people.

You are wrong.  Coreutils does not need selinux.  You should have
in lib/config.h:

/* Define to 1 if you have the <selinux/context.h> header file. */
/* #undef HAVE_SELINUX_CONTEXT_H */

/* Define to 1 if you have the <selinux/flask.h> header file. */
/* #undef HAVE_SELINUX_FLASK_H */

/* Define to 1 if you have the <selinux/selinux.h> header file. */
/* #undef HAVE_SELINUX_SELINUX_H */

If this is Chapter 5, then it might link selinux in, depending on the 
host.  In chapter 6, it definitely will not find those headers and there 
will be no problem.  If your host has the headers and not the libraries, 
then it is not set up properly.

   -- Bruce





More information about the lfs-support mailing list