Xorg problems, with libX11.so

xsystem xsysten at gmail.com
Fri Jan 22 06:37:12 PST 2010


xorg没有装好吧,按照BLFS手册试试,我的已经安装完成了!不知道哪个库没有弄好!

2010/1/20 stosss <stosss at gmail.com>

> You are Better off posting on the BLFS support list.
>
> On Wednesday, January 20, 2010, Joao Henriques <jf at netmadeira.com> wrote:
> > Ok,
> >
> > I'm getting this erros when making and installing xorg libs, in
> > libXpm-3.5.8 package:
> >
> > Making all in sxpm
> > make[2]: Entering directory `/sources/xorg/lib/libXpm-3.5.8/sxpm'
> >    CC     sxpm.o
> >    GEN    sxpm.1
> >    GEN    sxpm.po
> >    CCLD   sxpm
> > /usr/X11/lib/libX11.so: undefined reference to
> > `xcb_connection_has_error'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_poll_for_reply'
> > /usr/X11/lib/libX11.so: undefined reference to
> > `xcb_get_maximum_request_length'
> > /usr/X11/lib/libX11.so: undefined reference to
> > `xcb_get_file_descriptor'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_connect'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_wait_for_reply'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_get_setup'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_wait_for_event'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_poll_for_event'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_parse_display'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_generate_id'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_disconnect'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_take_socket'
> > /usr/X11/lib/libX11.so: undefined reference to `xcb_writev'
> > /usr/X11/lib/libX11.so: undefined reference to
> > `xcb_connect_to_display_with_auth_info'
> > collect2: ld returned 1 exit status
> > make[2]: *** [sxpm] Error 1
> > make[2]: Leaving directory `/sources/xorg/lib/libXpm-3.5.8/sxpm'
> > make[1]: *** [all-recursive] Error 1
> >
> > I already set :
> > X11_LIBS=/usr/X11/lib
> > and added /usr/X11/lib to /etc/lf.so.conf
> > and tried to build manually libX11 and libXpm with
> > LDFLAGS="-L${XORG_PREFIX}/lib" in configure.
> >
> > I'm building from svn.
> >
> > --
> > http://linuxfromscratch.org/mailman/listinfo/lfs-support
> > FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> > Unsubscribe: See the above information page
> >
> --
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20100122/1e22af4a/attachment.html>


More information about the lfs-support mailing list