Unable to boot from usb harddisk

Hans Kaper spakyelj at xs4all.nl
Thu Jan 21 13:48:42 PST 2010

Last september I posted a problem about not being able to boot from an USB  
That problem was solved by:
- inserting a kernel bootoption rootdelay=10,
- deleting a root=.... kernel bootoption, because the kernel starts  
looking for
initialisation info by default in its own partition first.

Recently I split the partition in front of the LFS-partition. I changed  
Grub's menu.lst and fstab accordingly. But then my problems returned.

First the kernel panicked, because it could not find its init. That was  
solved by inserting a root=sdc9 kernel-option anyway (although I thought  
that was unnecessary)(sdc9 is my LFS-partition).

A little later in the boot-proces the old kernel-panic - not syncing: VFS:  
Unable to mount root fs on unknown-block (2,0), returned. I increased the  
rootdelay to 20, but that made no difference (although I did not see the  
10 seconds extra on the screen, but that can have something to do with the  
fact that information is buffered first before it goes to the monitor)

Before this error occurs, the kernel enumerates the available partitions.  
There I see something like sdc9 > sdc4 (sdc9 is my LFS-partition). sdc4 is  
an ext2-partition that is empty.

It looks as though the kernel is looking somewhere else for its  
information than in its own partition.
Is there anywere else partition-information that the kernel uses? If yes,  
where is it stored?
Have I overlooked something?

More information about the lfs-support mailing list