gcc-4.4.2-startfiles_fix-1.patch fails

zzflop at embarqmail.com zzflop at embarqmail.com
Wed Jan 20 08:47:31 PST 2010

I just completed a build from LFS Version SVN-20100109. I
to tinker a little to get it working, but that is to be
expected with a development build.

My host system is a Live Disk 6.3 - jhalfs build.

When I tried to apply gcc-4.4.2-startfiles_fix-1.patch to
the freshly unpacked gcc-4.4.2 per intructions in chapter 5,
the patched failed to apply. I tried the compile anyway and
it failed as expected.

I looked at the patch and found the relevent section in
gcc.c and inserted the hunk manually and then did a diff
between my edited code and a freshly unpacked source and
the diff was the same except for the line numbers.

The line numbers on my patch are: @@ -6467,6 +6467,11 @@
The line numbers the book patch are: @@ -6370,6 +6370,11 @@

I tried the same thing with gcc-4.4.1 from the stable book
using gcc-4.4.1-startfiles_fix-1.patch and had the same 
result. They appear to be the same patch.

I used the search engine on the LFS website and perused the
mailing list archives manually , but didn't find anything
matching my circumstances.

My install seems to be working fine. I have compiled a few
of my favorites and gcc works fine. The testing in the final
phase of the gcc install was consistent with the references.

I am curious as to why this patch failed  for me and seems 
to work for others. Perhaps I wasn't persistent enough in
my search or overlooked something.

   Mike Hollis

More information about the lfs-support mailing list