GRUB configure error in LFS 6.5

Bruce Dubbs bruce.dubbs at gmail.com
Sun Jan 3 17:52:00 PST 2010


Felipe Sá wrote:
> When I try to configure GRUB-0.97 in section 8.4 of LFS 6.5 I get an 
> error saying that C compiler cannot create executables. Other previous 
> compiles were fine. Can anyone help?

LFS-6.5 uses grub legacy and that can't be built on an x86_64 system.

"This package will only build for x86 and x86_64 architectures 
containing 32-bit libs. If you chose to build on x86_64 without 32-bit 
libraries (no multilib), then you must use LILO instead. Information on 
“boot loading” for other architectures should be available in the usual 
resource-specific locations for those architectures. "

Depending on your original host architecture, LFS-6.5 builds a 'pure' 
64-bit system.  Try building GRUB2 from the -dev book.

http://www.linuxfromscratch.org/lfs/view/development/chapter06/grub.html
http://www.linuxfromscratch.org/lfs/view/development/chapter08/grub.html

   -- Bruce



More information about the lfs-support mailing list