bash 4.1 needs readline 6.1

Chris Staub chris at beaker67.com
Sat Jan 2 20:27:47 PST 2010


On 01/02/2010 05:37 PM, Bruce Dubbs wrote:
> Alexander Kozlov wrote:
>> On my machine, bash 4.1 builds happily with new readline and fails
>> with the 'old' 6.0. If it's not me only, this should be mentioned
>> in the "Host System Requirements", I think.
>
> I haven't looked at it, but it sounds like we will just need to add
> readline to Chapter 5.
>
>     -- Bruce

I don't think this is needed. If system Readline is specified, yes it 
does need to be 6.1. However, Bash 4.1 builds fine on my system (I have 
Readline 6.0 installed) if I simply leave out 
"--with-installed-readline" as it will, just like previous Bash 
versions, use its own internal Readline version.



More information about the lfs-support mailing list