Building Gettext-0.17 Error - LFS-6.5 Chapter 6.41

Justin P. Mattock justinmattock at gmail.com
Thu Oct 8 10:11:50 PDT 2009


Antony Derham wrote:
> I'm not sure what you mean. It is a 64-bit machine, however before 
> starting, I couldn't find anything about 64-bit support for LFS, so I 
> just began the book. Should I do something else?
>
> *From:* Spahn, Daniel <mailto:DSpahn at cuh2a.com>
> *Sent:* Tuesday, October 06, 2009 6:47 PM
> *To:* LFS Support List <mailto:lfs-support at linuxfromscratch.org>
> *Subject:* RE: Building Gettext-0.17 Error - LFS-6.5 Chapter 6.41
>
>
> > From: miklcct at gmail.com <mailto:miklcct at gmail.com>
> > To: lfs-support at linuxfromscratch.org 
> <mailto:lfs-support at linuxfromscratch.org>
> > Subject: Re: Building Gettext-0.17 Error - LFS-6.5 Chapter 6.41
> > Date: Tue, 6 Oct 2009 17:58:16 +0800
> >
> > On Tuesday 06 October 2009 00:23:47 Antony Derham wrote:
> > > /usr/bin/ld: ../gnulib-lib/.libs/libgettextlib.a(error-progname.o):
> > > relocation R_X86_64_32 against `a local symbol' can not be used when
> > > making a shared object; recompile with -fPIC
> > > ../gnulib-lib/.libs/libgettextlib.a: could not read symbols: Bad value
> > > collect2: ld returned 1 exit status
> > > make[4]: *** [libgettextsrc.la] Error 1
> > > make[4]: Leaving directory `/sources/gettext-0.17/gettext-tools/src'
> > > make[3]: *** [all] Error 2
> > > make[3]: Leaving directory `/sources/gettext-0.17/gettext-tools/src'
> > > make[2]: *** [all-recursive] Error 1
> > > make[2]: Leaving directory `/sources/gettext-0.17/gettext-tools'
> > > make[1]: *** [all] Error 2
> > > make[1]: Leaving directory `/sources/gettext-0.17/gettext-tools'
> > > make: *** [all-recursive] Error 1
> > >
> > > I ran
> > >
> > > ./configure --prefix=/usr --docdir=/usr/share/doc/gettext-0.17 && make
> > >
> > > and this is the error it gave me.
> > >
> > > Please can someone help me!?
> > >
> > > Thanks in advance!
> > >
> > > Antony
> >
> > Try
> >
> > make CFLAGS+=-fPIC
> >
> >Thanks for the reply.
> >
> >I tried using that command with the flag set, however it produced 
> exactly the same output, with the same error still. Is there possibly 
> anything I'm doing wrong?
> >
> >-Antony
>
> Looking at the error, it looks like a 64-bit-specific problem- Is the 
> system set up for multilib support?
>
> ------------------------------------------------------------------------
>
> Add other email accounts to Hotmail in 3 easy steps. Find out how. 
> <http://clk.atdmt.com/UKM/go/167688463/direct/01/>
>
> ------------------------------------------------------------------------
> -- 
> http://linuxfromscratch.org/mailman/listinfo/lfs-support
> FAQ: http://www.linuxfromscratch.org/lfs/faq.html
> Unsubscribe: See the above information page
If your looking into building
x86_64 multlib, or pure64 then go to
clfs:
http://cross-lfs.org/view/svn/
there they have done an excellent job of
creating tutorials for the flavor your trying to build

Justin P. Mattock



More information about the lfs-support mailing list