Building Gettext-0.17 Error - LFS-6.5 Chapter 6.41

Antony Derham antonyderham at hotmail.co.uk
Tue Oct 6 10:38:30 PDT 2009




> From: miklcct at gmail.com
> To: lfs-support at linuxfromscratch.org
> Subject: Re: Building Gettext-0.17 Error - LFS-6.5 Chapter 6.41
> Date: Tue, 6 Oct 2009 17:58:16 +0800
> 
> On Tuesday 06 October 2009 00:23:47 Antony Derham wrote:
> > /usr/bin/ld: ../gnulib-lib/.libs/libgettextlib.a(error-progname.o):
> >  relocation R_X86_64_32 against `a local symbol' can not be used when
> >  making a shared object; recompile with -fPIC
> >  ../gnulib-lib/.libs/libgettextlib.a: could not read symbols: Bad value
> >  collect2: ld returned 1 exit status
> > make[4]: *** [libgettextsrc.la] Error 1
> > make[4]: Leaving directory `/sources/gettext-0.17/gettext-tools/src'
> > make[3]: *** [all] Error 2
> > make[3]: Leaving directory `/sources/gettext-0.17/gettext-tools/src'
> > make[2]: *** [all-recursive] Error 1
> > make[2]: Leaving directory `/sources/gettext-0.17/gettext-tools'
> > make[1]: *** [all] Error 2
> > make[1]: Leaving directory `/sources/gettext-0.17/gettext-tools'
> > make: *** [all-recursive] Error 1
> > 
> > I ran
> > 
> > ./configure --prefix=/usr --docdir=/usr/share/doc/gettext-0.17 && make
> > 
> > and this is the error it gave me.
> > 
> > Please can someone help me!?
> > 
> > Thanks in advance!
> > 
> > Antony
> 
> Try
> 
> make CFLAGS+=-fPIC

Thanks for the reply.

I tried using that command with the flag set, however it produced exactly the same output, with the same error still. Is there possibly anything I'm doing wrong?

-Antony
 		 	   		  
_________________________________________________________________
Use Hotmail to send and receive mail from your different email accounts.
http://clk.atdmt.com/UKM/go/167688463/direct/01/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.linuxfromscratch.org/pipermail/lfs-support/attachments/20091006/ca17dbd1/attachment.html>


More information about the lfs-support mailing list